Smart Device Compatibility

We recognize that Owlet customers use a wide range of smartphone devices and various device operating systems. To ensure the best possible user experience, we test our iOS and Android applications on the two most recent operating systems (eg. iOS 13 / 14; Android 10 / 11). For the most stable performance, please keep your device operating system and Owlet app updated to the current available version.

While your Owlet Smart Sock and Camera should continue to work with older operating systems, the app can only be installed on devices running on the following operating systems:

  • iOS 13 or higher
  • Android 7 or higher

As we continue our software development efforts, our current applications may become less stable on older versions of device operating systems.

Owlet mobile applications are able to be downloaded on phones or tablets, however, it is not optimized for, or tested, on tablets.  The Owlet app does not support integration with smartwatches, smart speakers, or desktop/laptop computers.

Was this article helpful?
14 out of 31 found this helpful